Resolved
Fixed
Monitoring
We have identified the root cause of the Rapid Processor issue as a concurrency conflict. Multiple workers were attempting to write to the same file at the same time while finishing tasks, which resulted in a file lock and caused the processing system to freeze.
While safeguards were already in place, this specific edge case was not accounted for. A patch has now been deployed to properly handle concurrent write operations and prevent this condition from occurring.
We are actively monitoring system performance to ensure stability and confirm the issue is fully resolved.
Investigating
We are currently investigating an issue where the Rapid Processor may intermittently become stuck while saving posted alert IDs. When this occurs, it can cause the entire processing pipeline to hang, resulting in delays or missed alert deliveries.
Our team is actively working to identify the root cause and implement a fix. Updates will be provided as more information becomes available.