Today's scheduled maintenance has been successfully completed, and all Forecastix services have been restored.
During this maintenance window, we installed and configured new GPU hardware on our primary server and completed a series of load, stability, and performance tests. All systems have passed validation and are operating normally.
As part of this upgrade, Forecastix is now running on our next-generation mapping infrastructure. Map rendering is significantly faster, visual quality has been improved, and new mapping capabilities are now available across the platform.
Alert ingestion, processing, and posting services have resumed. Any alerts issued moving forward will be processed normally.
We appreciate everyone's patience during today's maintenance window. These upgrades provide the foundation for future enhancements, including expanded map customization options, improved performance, and additional mapping features planned for later this year.
Thank you for choosing Forecastix.
Complete
Today's scheduled maintenance has been successfully completed, and all Forecastix services have been restored.
During this maintenance window, we installed and configured new GPU hardware on our primary server and completed a series of load, stability, and performance tests. All systems have passed validation and are operating normally.
As part of this upgrade, Forecastix is now running on our next-generation mapping infrastructure. Map rendering is significantly faster, visual quality has been improved, and new mapping capabilities are now available across the platform.
Alert ingestion, processing, and posting services have resumed. Any alerts issued moving forward will be processed normally.
We appreciate everyone's patience during today's maintenance window. These upgrades provide the foundation for future enhancements, including expanded map customization options, improved performance, and additional mapping features planned for later this year.
Thank you for choosing Forecastix.
In progress
Maintenance work has been completed, and Forecastix services are now beginning to come back online.
Core systems are currently booting up and reconnecting to our processing infrastructure following the successful installation and configuration of new GPU hardware. Alert ingestion, processing, and posting services will be restored in phases as startup checks and validation tests are completed.
Users may experience brief delays while systems finish synchronizing and processing any queued data.
We will continue monitoring performance closely over the next several hours as final testing is completed.
Thank you for your patience during today's maintenance window as we continue upgrading Forecastix infrastructure to support future enhancements and improved platform performance.
In progress
Scheduled maintenance is now underway on our primary server.
We are currently installing and configuring new GPU hardware to support Forecastix's upcoming next-generation mapping system. Multiple load, stability, and performance tests will also be conducted throughout the maintenance period.
We expect maintenance activities to take approximately 30 to 90 minutes to complete, though the window may be extended if additional testing is required.
During this time, weather alerts will not be ingested, processed, or posted to connected platforms. Any alerts issued during the maintenance period may not be delivered by Forecastix.
We strongly encourage all users to have alternative methods of receiving weather warnings available, including NOAA Weather Radio, Wireless Emergency Alerts (WEA) on mobile devices, local media outlets, and National Weather Service products.
We will provide additional updates as work progresses and will notify users once services have been fully restored.
Thank you for your patience as we continue investing in infrastructure improvements that will enhance the reliability, performance, and future capabilities of Forecastix.
Scheduled
We will be conducting a scheduled maintenance window from 2:30 PM ET to 3:45 PM ET on Monday, June 15 for hardware installation and upgrades on our primary server.
During this maintenance period, we will be installing and configuring GPU hardware to support our upcoming next-generation mapping system and performing multiple load and performance tests.
Weather alert services will be unavailable during this window. Alerts will not be ingested, processed, or posted to any connected platforms while maintenance is underway. Any alerts issued during this period may not be delivered.
We recommend ensuring you have alternative methods of receiving weather warnings, such as NOAA Weather Radio, the Wireless Emergency Alerts system on your mobile device, or local National Weather Service products.
Weather Contingency: If a significant severe weather event is ongoing or expected to impact a large portion of our service area, this maintenance window may be postponed. However, due to coordination requirements and the availability of personnel involved in the hardware installation, this maintenance will not be postponed for isolated or routine severe weather events.
We appreciate your patience as we continue investing in infrastructure improvements that will enhance the reliability and performance of Forecastix.